PROBLEM
1 or more Azure backup locations fail to migrate:
CAUSE
If during the upgrade from V8 to V9, for some reason there is an issue connecting to the Azure Cloud location you had added, you will get a similar message to the above screenshot.
SOLUTION
In fact upon opening the console and visiting the [Backup Locations] screen, you will notice that your Azure location is now disconnected.
Open your Azure storage account portal and within the storage account, browse to [Containers] and create a new container to store your backups. Take note of the Container Name as you will be required to enter it later on.
In this case to re-authenticate the location, click on the Edit (pencil icon), as shown below:
Then click on the [Modify] button and then enter the Connection string or SAS token:
Finally, click [Test Connection] and [Finish]. You're now ready to take backups again to your Azure Cloud location.