Version 9
PROBLEM
You’re unable to connect to a network location and in the VM Backup Agent log file (C:\ProgramData\Hornetsecurity\VMBackup\Logs\Agent_Worker.log) you’re seeing a Windows Error 1219
CAUSE
A Windows Error 1219 occurs whenever you are attempting to connect to a network location from the same source machine using more than one user name. This will essentially create a conflict and result in such an error.
This is further documented on the following Microsoft KB article: https://support.microsoft.com/en-us/kb/938120
SOLUTION
- Ensure that you do not have a mapped drive to the network location you are trying to add. If you do, please disconnect the mapped drive and try again.
- Open up a command prompt window and run the command “net use”. This will display the machine’s list of network connections. If the network location you’re trying to add is in the list, delete that connection by using the following command:
net use <devicename> /delete
Then attempt to connect again.
- Check if you have any saved credentials in the Windows ‘Credential Manager’ that point to this location. If you do, please delete the saved credentials and try again.
- In some cases the connection might be open via the SYSTEM account and thereby we must use a tool called ‘PsExec’ (https://technet.microsoft.com/en-us/sysinternals/bb897553.aspx) in order to run the command prompt via the SYSTEM account.
In order to do this, extract the downloaded PsExec file in order to have an executable file. Then, open up a command prompt window and change directory to the path of the executable and type in: 'psexec.exe –i –s cmd.exe'.
This will launch the command prompt as the SYSTEM account; in order to confirm this – simply type in 'whoami' and it should show 'nt authority\system'.
Now simply run 'net use' again and if you do see the network location here, follow the steps explained in Step 2 to delete the connection and then try again.
- If you’re still unable to connect and still seeing a Windows Error 1219, you can use ‘Process Explorer’ (http://technet.microsoft.com/en-us/sysinternals/bb896653). By going to ‘Find’ ‘Find Handle’ you’ll be able to search via IP or hostname to see what other connections are open to the network location you’re trying to connect.
Version 8
PROBLEM
You’re unable to connect to a network location and in the VM Backup Agent log file (C:\ProgramData\Altaro\AltaroBackupProfile\Logs\AgentService.log) you’re seeing a Windows Error 1219
CAUSE
A Windows Error 1219 occurs whenever you are attempting to connect to a network location from the same source machine using more than one user name. This will essentially create a conflict and result in such an error.
This is further documented on the following Microsoft KB article: https://support.microsoft.com/en-us/kb/938120
SOLUTION
- Ensure that you do not have a mapped drive to the network location you are trying to add. If you do, please disconnect the mapped drive and try again.
- Open up a command prompt window and run the command “net use”. This will display the machine’s list of network connections. If the network location you’re trying to add is in the list, delete that connection by using the following command:
net use /delete
Then attempt to connect again.
- Check if you have any saved credentials in the Windows ‘Credential Manager’ that point to this location. If you do, please delete the saved credentials and try again.
- In some cases the connection might be open via the SYSTEM account and thereby we must use a tool called ‘PsExec’ (https://technet.microsoft.com/en-us/sysinternals/bb897553.aspx) in order to run the command prompt via the SYSTEM account.
In order to do this, extract the downloaded PsExec file in order to have an executable file. Then, open up a command prompt window and change directory to the path of the executable and type in: 'psexec.exe –i –s cmd.exe'.
This will launch the command prompt as the SYSTEM account; in order to confirm this – simply type in 'whoami' and it should show 'nt authority\system'.
Now simply run 'net use' again and if you do see the network location here, follow the steps explained in Step 2 to delete the connection and then try again.
- If you’re still unable to connect and still seeing a Windows Error 1219, you can use ‘Process Explorer’ (http://technet.microsoft.com/en-us/sysinternals/bb896653). By going to ‘Find’ ‘Find Handle’ you’ll be able to search via IP or hostname to see what other connections are open to the network location you’re trying to connect.