Note: This also applies for Exchange Item Level Restore.
PROBLEM
During a File level restore, you encounter the error "No Valid Partitions" when selecting your Virtual Disk.
CAUSE
For VM Backup to be able to successfully browse the guest partitions and make them available for instant item level restore, the following must be true for the VM in question:
- The partition must be NTFS/ReFS formatted
- The partition must be formatted as 'Basic' and not 'Dynamic'
- The VM must NOT have Windows Deduplication enabled
- The files must NOT be encrypted or compressed at guest OS (VM) level
- Check that the backup was not taken with a warning (Crash Consistent)
- Storage spaces volumes are not supported.
Note: Granular Level Restore from an Offsite Backup Server / Cloud Backup locations are not supported.
SOLUTION
Note: Selecting a blank Virtual Disk from the drop-down list will result in this error. The below information assumes that you are indeed selecting a Virtual Disk that contains data.
Attempt an Instant Mount from Virtual Disk or perform a restore clone, which by default VM Backup will disable the restored VM's NIC so it will not have any affect on your production environment. Instructions on instantly mounting the virtual disk can be found here.