PROBLEM
OST files within a VM are cleared out upon a backup job, hence when Microsoft VSS runs within the VM.
CAUSE
VM Backup, like other backup solutions is a VSS requestor, meaning that we make use of the Microsoft Volume Shadow Copy Service (VSS); naturally this only takes place whenever the option for Application Consistent backups is enabled for a VM.
The .OST files will get cleared off by a VSS job (such as the one triggered by a backup). This can also be replicated by taking a Production Checkpoint for instance. By default, VSS will exclude specific files from the VSS snapshot request, which is dictated by the FilesNotToSnapshot registry key.
This is documented further on Microsoft's Docs here: https://docs.microsoft.com/en-gb/windows/desktop/Backup/registry-keys-for-backup-and-restore
SOLUTION
Perform the steps below on the VM(s) showing the event log errors above:
- Open the Registry Editor (Start - Run - enter "regedit", hit enter)
Warning: Incorrect changes to the Registry can prevent the operating system from functioning correctly. modifications should be done by personnel who are experienced in it's use. We strongly recommend that you back up your existing registry before proceeding
- Navigate to the entry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\BackupRestore\FilesNotToSnapshot
- Delete the entry for OutlookOST
- Reboot the VM(s) after making registry changes
- The .OST files should now be backed up as well as not cleared out.