PROBLEM
Backup for some VMs failing with Error: "Backup failed due an error in the Microsoft Shadow Copy component" and VSS Error: 0x800423F3
- AND -
The Application Event log on the target VM that fails shows errors with Event ID 12292 and Event ID 22 as follows:
Event ID: 12292
Source: VSS
Level: Error
Description:
Volume Shadow Copy Service error: Error creating the Shadow Copy Provider COM class with CLSID {79079d5c-ef20-4952-b9fc-cfd443b38641} [0x80040154, Class not registered]
Obtain a callable interface for this provider
List interfaces for all providers supporting this context
Query Shadow CopiesContext:
Provider ID: {f782463b-33bb-4043-ad8d-60b728d26a6c}
Class ID: {79079d5c-ef20-4952-b9fc-cfd443b38641}
Snapshot Context: -1
Snapshot Context: -1
Execution Context: Coordinator
Event ID: 22
Source: VSS
Level: Error
Description:
Volume Shadow Copy Service error: A critical component required by the Volume Shadow Copy service is not registered. This might happened if an error occurred during Windows setup or during installation of a Shadow Copy provider. The error returned from CoCreateInstance on class with CLSID {79079d5c-ef20-4952-b9fc-cfd443b38641} and Name SW_PROV is [0x80040154, Class not registered].
Obtain a callable interface for this provider
List interfaces for all providers supporting this context
Query Shadow CopiesContext:
Provider ID: {f782463b-33bb-4043-ad8d-60b728d26a6c}
Class ID: {79079d5c-ef20-4952-b9fc-cfd443b38641}
Snapshot Context: -1
Snapshot Context: -1
Execution Context: Coordinator
CAUSE
This is caused by the Acronis VSS provider being left behind after the product has been previously uninstalled.
SOLUTION
Perform the steps below on the VM(s) showing the event log errors above:
- Open the Registry Editor (Start -> Run -> enter "regedit", hit enter)
Warning: Incorrect changes to the Registry can prevent the operating system from functioning correctly. modifications should be done by personnel who are experienced in it's use. We strongly recommend that you back up your existing registry before proceeding
- Navigate to the entry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\VSS\Providers
- Right-click on the entry with GUID {f782463b-33bb-4043-ad8d-60b728d26a6c} and export it to a file for backup purposes
- Delete the tree with the GUID {f782463b-33bb-4043-ad8d-60b728d26a6c}
- Reboot the VM(s) after making registry changes
- Run the backup job again. If backup still fails, restart the Hyper-V Host