In diesem Artikel erfahren Sie, wie Sie eine HAR-Datei in Ihrem Browser erstellen.
In manchen Fällen bittet der Hornetsecurity Support Sie um eine HAR-Datei, um ein gemeldetes Problem genauer zu analysieren. Eine HAR-Datei enthält aufgezeichnete Netzwerkanfragen des Browsers. Dadurch kann der Support nachvollziehen, welche Anfragen beim Auftreten des Fehlers gesendet und beantwortet wurden.
Wichtiger Sicherheitshinweis!
Eine HAR-Datei kann sensible Daten enthalten, zum Beispiel:
- Anmeldedaten
- Sitzungstoken
- Cookies
- personenbezogene Daten
- Inhalte aus Formularfeldern
Entfernen Sie sensible Daten aus der HAR-Datei, bevor Sie die Datei an Hornetsecurity senden.
Öffnen Sie die HAR-Datei dazu mit einem Texteditor und suchen Sie nach Begriffen wie password, token, cookie oder authorization. Ersetzen Sie sensible Werte durch Platzhalter, zum Beispiel *****.
Chrome
- Öffnen Sie Chrome und rufen Sie die Seite auf, auf der das Problem auftritt.
- Suchen Sie nach der Schaltfläche ⋮ und wählen Sie Weitere Tools > Entwicklertools aus. Oder Sie drücken die F12 Taste auf der Tastatur.
- Wählen Sie im daraufhin eingeblendeten Fenster die Registerkarte Netzwerk aus. Sie müssen das Menü geöffnet lassen, während Sie das Problem reproduzieren.
- Drücken Sie vor dem Start der Aufnahme einmal auf das kleine Symbol neben dem roten Aufnahme-Symbol um bisher aufgezeichnete Ereignisse zu löschen.
- Machen Sie oben links in der Registerkarte die runde Aufzeichnungsschaltfläche ausfindig, und stellen Sie sicher, dass sie rot ist. Wenn sie grau ist, klicken Sie einmal auf die Schaltfläche, um die Aufzeichnung zu starten.
- Ist dies nicht der Fall, aktivieren Sie das Kontrollkästchen Protokoll beibehalten.
- Klicken Sie auf die Schaltfläche mit dem durchgestrichenen Kreis, um alle vorhandenen Protokolle von der Registerkarte „Netzwerk“ zu löschen.
- Reproduzieren Sie das Problem, während die Netzwerkanfragen aufgezeichnet werden.
- Klicken Sie auf die Schaltfläche zum Herunterladen, Export HAR, um die Datei herunterzuladen und auf Ihrem Computer zu speichern: Mit Content als HAR speichern. Alternativ können Sie mit der rechten Maustaste auf eine beliebe Stelle in der Spalte Name klicken und wählen Alle als HAR mit Inhalt speichern
-
Wichtig: Entfernen Sie Ihre persönliche Anmeldedaten aus der Datei. Dazu öffnen Sie die HAR-Datei mit einem Texteditor und suchen nach
"password". Lokalisieren Sie Ihr Passwort im Klartext und ersetzen dieses mit einem Platzhalter (z.B. "*****"). Speichern Sie die Datei ab. - Sie sind fertig! Bitte senden Sie uns die HAR-Datei, damit wir die Analyse fortführen können.
Nachfolgend finden Sie eine kurze Animation mit den Schritten zum Abrufen einer HAR-Datei in Chrome.
Firefox
- Öffnen Sie Firefox und rufen Sie die Seite innerhalb des Control Panels auf, auf der das Problem auftritt.
- Wählen Sie das Firefox-Menü (drei horizontale, parallele Linien) oben rechts in Ihrem Browser-Fenster und wählen Sie dann Weitere Werkzeuge > Werkzeuge für Web-Entwickler. Oder Sie drücken die F12 Taste auf der Tastatur.
- Wählen Sie im daraufhin eingeblendeten Fenster die Registerkarte Netzwerkanalyse aus. Sie müssen das Menü geöffnet lassen, während Sie das Problem reproduzieren.
- Entfernen Sie den aktuellen Verlauf, indem Sie auf das Papierkorbsymbol klicken.
- Reproduzieren Sie das Problem, während die Netzwerkanfragen aufgezeichnet werden.
- Klicken Sie mit der rechten Maustaste auf eine beliebige Stelle unter der Spalte Datei und klicken Sie auf Alle als HAR speichern.
- Speichern Sie die HAR-Datei an einem geeigneten Ort.
-
Wichtig: Entfernen Sie Ihre persönliche Anmeldedaten aus der Datei. Dazu öffnen Sie die HAR-Datei mit einem Texteditor und suchen nach
"password". Lokalisieren Sie Ihr Passwort im Klartext und ersetzen dieses mit einem Platzhalter (z.B. "*****"). Speichern Sie die Datei ab. - Sie sind fertig! Bitte senden Sie uns die HAR-Datei, damit wir die Analyse fortführen können.
Nachfolgend finden Sie eine kurze Animation mit den Schritten zum Abrufen einer HAR-Datei in Firefox.
Safari
- Öffnen Sie Safari und gehen Sie zum Menü Entwickeln. Wenn Sie das Menü Entwickeln nicht sehen, befolgen Sie die Anweisungen in diesem Beitrag im Safari-Benutzerhandbuch: Verwenden Sie die Entwicklertools im Menü „Entwickeln“ in Safari auf dem Mac.
- Wählen Sie Webinformationen anzeigen. Oder drücken Sie ⌥ + ⌘ + I
- Entfernen Sie den aktuellen Verlauf, indem Sie auf das Papierkorbsymbol klicken.
- Klicken Sie auf die Registerkarte Netzwerk. Sie muss geöffnet bleiben, während Sie das Problem reproduzieren.
- Reproduzieren Sie das Problem, während die Netzwerkanfragen aufgezeichnet werden.
- Klicken Sie auf das Symbol Exportieren und speichern Sie die HAR-Datei.
-
Wichtig: Entfernen Sie Ihre persönliche Anmeldedaten aus der Datei. Dazu öffnen Sie die HAR-Datei mit einem Texteditor und suchen nach
"password". Lokalisieren Sie Ihr Passwort im Klartext und ersetzen dieses mit einem Platzhalter (z.B. "*****"). Speichern Sie die Datei ab. - Sie sind fertig! Bitte senden Sie uns die HAR-Datei, damit wir die Analyse fortführen können.
Wenn Sie Probleme beim Generieren einer HAR-Datei in Safari haben, lesen Sie diesen Beitrag auf der Safari-Entwicklerwebsite: Web-Inspektor.
Edge
- Öffnen Sie Edge und rufen Sie die Seite auf, auf der das Problem auftritt.
- Suchen Sie nach der Schaltfläche mit den drei horizontalen Punkten und wählen Sie Weitere Tools > Entwicklertools aus. Oder Sie drücken die F12 Taste auf der Tastatur.
- Wählen Sie im daraufhin eingeblendeten Fenster die Registerkarte Netzwerk aus. Sie müssen das Menü geöffnet lassen, während Sie das Problem reproduzieren.
- Drücken Sie vor dem Start der Aufnahme einmal auf das kleine Symbol neben dem roten Aufnahme-Symbol um bisher aufgezeichnete Ereignisse zu löschen.
- Machen Sie oben links in der Registerkarte die runde Aufzeichnungsschaltfläche ausfindig, und stellen Sie sicher, dass sie rot ist. Wenn sie grau ist, klicken Sie einmal auf die Schaltfläche, um die Aufzeichnung zu starten.
- Ist dies nicht der Fall, aktivieren Sie das Kontrollkästchen Protokoll beibehalten.
- Klicken Sie auf die Schaltfläche mit dem durchgestrichenen Kreis, um alle vorhandenen Protokolle von der Registerkarte „Netzwerk“ zu löschen.
- Reproduzieren Sie das Problem, während die Netzwerkanfragen aufgezeichnet werden.
- Klicken Sie auf die Schaltfläche zum Herunterladen, Export HAR, um die Datei herunterzuladen und auf Ihrem Computer zu speichern: Mit Content als HAR speichern. Alternativ können Sie mit der rechten Maustaste auf eine beliebe Stelle in der Spalte Name klicken und wählen Alle als HAR mit Inhalt speichern
-
Wichtig: Entfernen Sie Ihre persönliche Anmeldedaten aus der Datei. Dazu öffnen Sie die HAR-Datei mit einem Texteditor und suchen nach
"password". Lokalisieren Sie Ihr Passwort im Klartext und ersetzen dieses mit einem Platzhalter (z.B. "*****"). Speichern Sie die Datei ab. - Sie sind fertig! Bitte senden Sie uns die HAR-Datei, damit wir die Analyse fortführen können.
Nachfolgend finden Sie eine kurze Animation mit den Schritten zum Abrufen einer HAR-Datei in Edge.